Question: Intermittent issues logging into MapKnitter

warren is asking a question about mapknitter
Follow this topic

by warren | May 04, 2021 17:24 | #26489

We've observed some occasional issues with MapKnitter logins (this may also affect Spectral Workbench), but unfortunately (or fortunately) they are intermittent; sometimes just "trying again" works. This is frustrating, not least because we are having trouble fixing them, but the upside is that we haven't yet encountered a situation where we /cannot/ log in.


  1. The first time we saw this was upon trying to log into using a GitHub account (the leftmost bottom button in the screenshot below). However upon logging into (even with a GitHub account) and then logging into MapKnitter using our account (the top button below) it worked.
  2. The second time, logging into MapKnitter with a GitHub account worked, but left us at the dashboard. But, then logging into MapKnitter using GitHub OAuth worked.


Please leave comments if you've also experienced this, and please note the following to both help us debug it as well as to help us help you if you get stuck:

  1. what were you already logged into and how (i.e. did you log in with Twitter, Facebook or GitHub, or just make an account manually with an email address)
  2. what did you then try to log into and how
  3. what was each step you took and what did you see upon each step (here, screenshots including the URL bar are really helpful)
  4. what error pages, if any, did you see (again screenshots with URL bar are helpful)

Thank you and apologies for any trouble you might be having!


Log in to comment